[ngw] GW8 on OES2 SP3 (vSphere 5): Lots of errors [8209, D01B, EA10, C006] in POA log

Thieu Hon TRAN k-ngwlist at thtran.de
Fri Sep 21 10:33:55 UTC 2012


Hello,

we're running GW8.0.2 (Build 92377) on OES2 SP3, SLES 10 SP3. The 
Groupwise server is a virtual machine running under vSphere5 (2 vCPUs, 4 
GB RAM)
There was some major problem on the groupwise-server yesterday. (Almost) 
all Users (including me) saw a their GW-client was "freezed" for several 
Minutes or even more than 15 Minutes. We are in the same location as the 
GW-server. I could not find the reason, yet.

Currently, I'm seeing lots of error messages like these:
|----------------------------------------------------------------------|
10:01:49 232 The database function 14 reported error [8209] on wphost.db
10:01:49 232 The database function 14 reported error [8209] on wphost.db
10:05:09 784 The database function 14 reported error [8209] on wphost.db
10:05:09 784 The database function 14 reported error [8209] on wphost.db
10:06:21 232 The database function 14 reported error [8209] on wphost.db
10:06:21 232 The database function 14 reported error [8209] on wphost.db
10:06:26 968 Error: A record, key, or key reference was not found [C006] 
User:WilA  (WilA)
10:07:57 232 The database function 14 reported error [8209] on wphost.db
10:07:57 232 The database function 14 reported error [8209] on wphost.db
10:07:58 016 The database function 14 reported error [8209] on wphost.db
10:07:58 016 The database function 14 reported error [8209] on wphost.db
10:08:10 512 Error streaming an attachment [D01B]
10:11:21 784 Error streaming an attachment [D01B]
10:14:34 608 The database function 14 reported error [8209] on wphost.db
10:14:34 232 The database function 14 reported error [8209] on wphost.db
10:14:34 232 The database function 14 reported error [8209] on wphost.db
10:14:34 608 The database function 14 reported error [8209] on wphost.db
10:14:34 608 Error streaming an attachment [EA10]
10:14:34 512 The database function 14 reported error [8209] on wphost.db
10:14:34 512 The database function 14 reported error [8209] on wphost.db
10:14:34 512 Error streaming an attachment [EA10]
10:19:08 232 Error streaming an attachment [D01B]
10:19:08 608 Error streaming an attachment [D01B]
10:20:27 608 The database function 14 reported error [8209] on wphost.db
10:20:27 608 The database function 14 reported error [8209] on wphost.db
10:21:15 784 Error streaming an attachment [D01B]
10:21:27 232 Error streaming an attachment [D01B]
10:26:04 232 Error streaming an attachment [D01B]
10:26:04 512 Error streaming an attachment [D01B]
10:28:26 512 The database function 14 reported error [8209] on wphost.db
10:28:26 512 The database function 14 reported error [8209] on wphost.db
10:30:51 608 Error streaming an attachment [D01B]
10:33:31 512 Error streaming an attachment [D01B]
10:33:31 608 Error streaming an attachment [D01B]
10:33:32 512 The database function 14 reported error [8209] on wphost.db
10:33:32 512 The database function 14 reported error [8209] on wphost.db
10:34:21 512 Error streaming an attachment [D01B]
10:35:07 000 Error: A record, key, or key reference was not found [C006] 
User:OrlH  (OrlH)
10:35:40 608 Error streaming an attachment [D01B]
|----------------------------------------------------------------------|

And a couple of messages because of slap connections:
|----------------------------------------------------------------------|
0921poa.001:00:18:33 280 Error writing the slap connection response 
message [8911]
0921poa.002:08:25:37 792 Error writing the slap connection response 
message [8911]
0921poa.002:08:37:11 584 Error writing the slap connection response 
message [8911]
0921poa.002:08:40:39 736 Error writing the slap connection response 
message [8911]
0921poa.002:09:17:55 976 Error writing the slap connection response 
message [8911]
0921poa.002:09:44:37 304 Error writing the slap connection response 
message [8911]
0921poa.003:11:01:46 976 Error writing the slap connection response 
message [8911]
|----------------------------------------------------------------------|

I found a TID (http://www.novell.com/support/kb/doc.php?id=7007984) 
stating that "The database function 14 reported error [8209] on 
wphost.db" "looks like a cosmetics error".
I think our Groupwise-system matches all criteria mentioned in this TID: 
We do have OES2 on SLES10, we do use NSS-filesystem for Groupwise and 
there a two trusted apps configured, one for mail-archiving and one for 
DataSync. I'm not sure what is meant with "trusted application feature 
to provide grace login in Groupwise".

How can I be sure that TID 7007984 applies in this case? I used the command
    egrep -i "(soap|function)" 0921poa.00*|less
to filter all messages regarding "function 14" and soap out of the 
POA-log. There does seem to be a coincidence. The "function 14 ... 
[8209]"-messages are following soap-loginRequest/logoutRequest events, 
and they have the same "task-number" (?) (the 3-digit-number after the 
timestamp)

I've validated the domain-db and post-office-databases of all 
post-offices on this server. Console1 didn't find a problem when 
validating. I recovered the domain-db and post-office-dbs anyway.

Then I ran a structure and contents check for the two users WilA and 
OrlH because of the error "key reference not found [C006]", but GWCHECK 
said "No problems found".

The Groupwise-server seems to work normally today. I haven't heard any 
user complaints so far (it's lunch time now). But I'm still getting 
those "key reference was not found [C006]" errors. How do I get rid of them?

    Hon.


More information about the ngw mailing list