[ngw] Rule does not fire for SOAP created message. Known problem?

Joe Acquisto-j4 joea at j4computers.com
Fri Dec 27 16:40:22 UTC 2013


I could be mis remembering, but seems "forward as attachment" had issues via rules.  For it to work reliably, had to "delegate" and not forward.

joe a.

>>> "David Gerisch" <DGerisch at co.tulare.ca.us> 12/26/13 5:44 PM >>>
Is anyone aware of a problem with rules not firing for messages created by SOAP?

We have an application that converts voice mails into .wav files, and then emails the .wav files into GroupWise.  One of my users wants the message forwarded as an attachment, via a rule.  If I change the rule condition to be From = me, and send her a message, the forward works.  When I change the rule condition to be From = VMAgent and generate a voice mail, the forward does not automatically work.  (If I highlight the rule and manually Run it, the forward DOES work - so it does not appear to be a case of having gotten the name wrong).

So I went to another user on another post office, and replicated the problem.  I've also tried the condition "Attachments contain voicemessage.wav".

The only thing I can think of that is different between the voice mail application and me just hitting Send is that the voice mail application is creating the messages and delivering them via SOAP.  The mailbox it uses does not have items in it's Sent Items folder.  The POA log file does have log entries that say "Distributed message from: VMAgent     App( SOAP ).  The log does not have a follow up "Execute forward rule".

Anyone know if this is working as designed or a known bug (or just discovered bug)?

GroupWise 2012 Support Pack 2

Thanks!

David Gerisch

_______________________________________________
ngw mailing list
ngw at ngwlist.com
http://ngwlist.com/mailman/listinfo/ngw




More information about the ngw mailing list