[ngw] Antw: Re: GW2014 LDAP Server can't be removed

Barth Uwe Uwe.Barth at stadt-chemnitz.de
Thu Jul 31 13:38:59 UTC 2014


Thanks for your information but I think my lab-environment is nearly dead now. ;-)

I tried Morris' steps with no success. The curl command returns the following error using the buildin admin user and correct password.
<error>true</error>
<httpStatus>UNAUTHORIZED</httpStatus>
<httpStatusCode>401</httpStatusCode>
<status Msg>Unable to find Admin Service: my.fqdn:9710<statusMsg>

I think I'll switch back to my GW2012 snapshots and start from scratch.

Greetings 
Uwe



>>> "Morris Blackham" <mblackham at gw.novell.com> 29.07.2014 17:30 >>>
Dang,  bug...  Developer is fixing as we speak.   But here's a way to allow you to delete the directory.

1. In the admin Console,  select the MTA's to list all the MTA's

2.  In the filter field (right hand side above the mta list) Enter a filter of "syncLdapServerName != null" .  This will give you a list of MTA's that have the sync flag set.

3.  Now the fun part...   From a Linux terminal window enter this command for any MTA's you found for the filter above.

curl -k --user gwadmin:password -H "Content-type:application/json" --data "{\"syncLdapServerName\":\"\"}" -X PUT https://youradminserverip:9710/gwadmin-service/domains/yourdomainname/mta 

make sure you get all the escaped quotes correct inside the { } for the data portion and the syncLdapServerName tag is case sensitive..

--Morris
>>> "Barth Uwe" <Uwe.Barth at stadt-chemnitz.de> 7/29/2014 6:31 AM >>>
Hi everyone,

in preparation of our update to GW2014 in november I played around a little bit in my lab-environment. I've updated from GW2012/OES11 without any huge problems (beside the one described in TID7014850).

Now I want to change the directory sync from eDirectory to Active Directory beginning with clearing all entries in "LDAP Servers" and "Directory Associations" in admin console. The problem is now that I can't remove the old LDAP servers. The error message says "Delete failed for object 'xyz123' (Deletion failed. The LDAP Server is being used for eDirectory synchronization (0xDB5A).)". 
Does somebody has an idea how to remove this entries? I've removed the scheduled events for MTA and all know associations in POA, but no success. Admin console does not have an equivalent to the "eDirectory Synchonization"-Tab in C1 as far as I can see.

Greetings, 
Uwe



_______________________________________________
ngw mailing list
ngw at ngwlist.com 
http://ngwlist.com/mailman/listinfo/ngw 





More information about the ngw mailing list