[ngw] Foreign ID Field on GW2014 R2

Morris Blackham mblackham at microfocus.com
Thu Feb 25 20:55:59 UTC 2016


to remove the foreign ID values:

curl -k --user admin:pwd -H "content-type:application/json" -X PUT --data "{\"foreignId\":\"\"}" https://10.10.10.10:9710/gwadmin-service/domains/mydomain/gwias/gwia

will remove all data,   If you need to add some data back in:

curl -k --user admin:novell -H "content-type:application/json" -X PUT --data "{\"foreignId\":\"skippy.com acme.com\"}" https://151.155.136.194:9710/gwadmin-service/domains/arizona/gwias/gwia

But,  instead of adding them back using the curl command,  you'd be better off creating a frgnames.cfg file.   See http://www.novell.com/support/kb/doc.php?id=3794830

--Morris
>>> Marvin Huffaker <mhuffaker at redjuju.com> 2/25/2016 12:03 PM >>>
I have a situation where my GWIA is utilizing the Foreign ID field on the GWIA and it is set to an old domain that is no longer valid. This is causing issues with autoresponded messages generated by the GWIA.   I can confirm that this is the case from the Log Files, but also the attribute shows on the GW2014R2 GWIA Agent HTTP Page.. On the Configuration Tab, it's listed as the 1st item on the page.  I can see the invalid domain that it is configured with. 

The problem is that it appears that in GW2014R2 I no longer have access to this Foreign ID field. In ConsoleOne it was always there. In the GW2014 Admin console, It's just gone.

How do I clear this attribute?

Marvin

Marvin Huffaker
mhuffaker at redjuju.com
Office:  480-988-7215 (Best Number)
Cell: 480-797-2989 




More information about the ngw mailing list