[ngw] GWHA Problem After Upgrade

Gregg A. Hinchman Gregg at HinchmanConsulting.com
Wed Jan 13 14:18:15 UTC 2016


Excellent write up Matt. Thanks!!



I am sure others have not even consider this nor tested it. GWHA just 'worked' in the past.





Take Care.
 
Gregg A. Hinchman, PMP

Consultant
Gregg at HinchmanConsulting.com 

www.HinchmanConsulting.com

VMWare VCP5

765.653.8099 Office
413.254.2819 eFax

 

"Courage is doing what is right." 


"Do not be bound to any doctrine, theory or ideology, even Buddhist ones. All systems of thought are guiding means, not absolute truth."  Thich Nhat Hanh, Vietnamese monk.




>>> 
From: Matt Weisberg<matt at weisberg.net>
To:NGWList<ngw at ngwlist.com>
Date: 1/12/2016 9:16 PM
Subject: [ngw] GWHA Problem After Upgrade



I had a site I recently upgraded from GroupWise 2012 to 2014 R2.  Most of the servers were SLES 11 SP4.  The upgrade went fine, but I could not get the GWHA service to restart a failed PO.  Everything looked configured correctly, so I tried telnetting to port 8400 on one of the upgraded servers:

Trying 192.168.0.38...
Connected to dvcpo.
Escape character is '^]'.
gwha: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
Connection closed by foreign host.


I tested the one server that was a fresh SLES 12 SP1 install and it did not have this issue.

I discovered that after the upgrade, the gwha configuration in /etc/xinet.d was not updated properly, it looked like this:

service gwha
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /opt/novell/groupwise/agents/bin/gwha
    instances = 1
    type = UNLISTED
    port = 8400
}


It was missing the environment setting for the library path, so gwha couldn’t find the libraries it needed, so I changed it to this:

service gwha
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /opt/novell/groupwise/agents/bin/gwha
        instances       = 1
        type            = UNLISTED
        port            = 8400
        env             = LD_LIBRARY_PATH=/opt/novell/groupwise/agents/lib
}

And restarted xinetd (rcxinetd restart) and everything started working.

I think this is a bug in the upgrade process.  I checked some other sites that I had upgraded and they were all missing the library path in the gwha xinetd config.


Hope that saves someone some grief!

Matt

—
Matt Weisberg
Weisberg Consulting, Inc.
matt at weisberg.net
www.weisberg.net
ofc. 248.685.1970
cell 248.705.1950
fax 248.769.5963

_______________________________________________
ngw mailing list
ngw at ngwlist.com
http://ngwlist.com/mailman/listinfo/ngw


More information about the ngw mailing list