[ngw] GWHA Problem After Upgrade

David Krotil David.Krotil at hilo.cz
Fri Jan 15 09:44:11 UTC 2016


I had SR opened for crashing of gwdva and I got information, that this
is normal, because crashing is by design. If the indexer gets corrupted
file, it will crash. 
I think there isn´t any DCA on 14.2, only DVA. Because DCA is old
method of file conversion.

David

------------------------------------------------------------------
Obsah tohoto e-mailu a všechny připojené soubory jsou důvěrné a mohou
být chráněny zákonem. Tento e-mail je určen výhradně jeho adresátovi
a jiné osoby do něj nejsou oprávněny nahlížet či s ním jakkoliv
nakládat, jinak se dopustí protiprávního jednání. V případě, že
nejste adresátem tohoto e-mailu, prosíme o jeho vymazání a o podání
e-mailové zprávy. 

The content of this e-mail and any attached files are confidential and
may be legally privileged. It is intended solely for the addressee.
Access to this e-mail by anyone else is unauthorized. If you are not the
intended recipient, any disclosure, copying, distribution or any action
taken or omitted to be taken in reliance on it, is prohibited and may be
unlawful. In this case be so kind and delete this e-mail and inform us
about it.

>>> "Daniel Wells" <Daniel.Wells at mhtn.com> 14.01.2016 16:32 >>>
This will help me greatly.  At least in our case the upgrade from
14.0.2
to 14.2 has had a large number of issues.  The "gwdva" crashes every
60-90 minutes unless the post office dca filter has PDF files listed. 
I
noticed the gwha problem but had not gotten to that yet.  The client
has
issues...  it was not a good way for Micro Focus to start their
GroupWise reign.



Daniel Wells AIA, VCP
Senior Associate | IT Coordinator
MHTN Architects, Inc.
Direct: 801.326.3215 | www.mhtn.com
vision made real



Confidentiality Notice: This e-mail, including attachments, are
privileged and confidential and/or proprietary information intended
solely for the use of the individual or entity to whom this is
addressed. If the reader of this message is not the intended
recipient,
or the employee or agent responsible to deliver it to the intended
recipient, you are hereby notified that any dissemination,
distribution
or copying of this communication is strictly prohibited. If you
received
this communication in error, please immediately notify sender by
telephone or reply email, do not use or disclose the contents to
others,
and delete the message and all attachments from your computer, system
and/or network. Further, e-mail transmission cannot be guaranteed to
be
secure or error-free as information could be intercepted, corrupted,
lost, destroyed, arrive late or incomplete, or contain viruses. The
sender therefore does not accept liability for any errors or omissions
in the contents of this message, which arise as a result of e-mail
transmission. If verification is required please request a hard-copy
version.

>>> "Gregg A. Hinchman" <Gregg at HinchmanConsulting.com> 1/13/2016 7:18
AM
>>>

Excellent write up Matt. Thanks!!



I am sure others have not even consider this nor tested it. GWHA just
'worked' in the past.





Take Care.
Gregg A. Hinchman, PMP

Consultant
Gregg at HinchmanConsulting.com 

www.HinchmanConsulting.com

VMWare VCP5

765.653.8099 Office
413.254.2819 eFax


"Courage is doing what is right." 


"Do not be bound to any doctrine, theory or ideology, even Buddhist
ones. All systems of thought are guiding means, not absolute truth." 
Thich Nhat Hanh, Vietnamese monk.




>>> 
From: Matt Weisberg<matt at weisberg.net>
To:NGWList<ngw at ngwlist.com>
Date: 1/12/2016 9:16 PM
Subject: [ngw] GWHA Problem After Upgrade



I had a site I recently upgraded from GroupWise 2012 to 2014 R2.  Most
of the servers were SLES 11 SP4.  The upgrade went fine, but I could
not
get the GWHA service to restart a failed PO.  Everything looked
configured correctly, so I tried telnetting to port 8400 on one of the
upgraded servers:

Trying 192.168.0.38...
Connected to dvcpo.
Escape character is '
^]'.
gwha: error while loading shared libraries: libssl.so.1.0.0: cannot
open shared object file: No such file or directory
Connection closed by foreign host.


I tested the one server that was a fresh SLES 12 SP1 install and it
did
not have this issue.

I discovered that after the upgrade, the gwha configuration in
/etc/xinet.d was not updated properly, it looked like this:

service gwha
{	    socket_type     = stream
	    protocol  	  = tcp
	    wait  		  = no
	    user  		  = root
	    server  	    =
/opt/novell/groupwise/agents/bin/gwha
    instances = 1
    type = UNLISTED
    port = 8400
}
It was missing the environment setting for the library path, so gwha
couldn’t find the libraries it needed, so I changed it to this:

service gwha
{	    socket_type     = stream
	    protocol  	  = tcp
	    wait  		  = no
	    user  		  = root
	    server  	    =
/opt/novell/groupwise/agents/bin/gwha
	    instances  	 = 1
	    type  		  = UNLISTED
	    port  		  = 8400
	    env  		   =
LD_LIBRARY_PATH=/opt/novell/groupwise/agents/lib
}And restarted xinetd (rcxinetd restart) and everything started
working.

I think this is a bug in the upgrade process.  I checked some other
sites that I had upgraded and they were
all missing the library path in
the gwha xinetd config.


Hope that saves someone some grief!

Matt

—
Matt Weisberg
Weisberg Consulting, Inc.
matt at weisberg.net
www.weisberg.net
ofc. 248.685.1970
cell 248.705.1950
fax 248.769.5963

_______________________________________________
ngw mailing list
ngw at ngwlist.com
http://ngwlist.com/mailman/listinfo/ngw





More information about the ngw mailing list