[ngw] dbcopy not working

Matt Schlawin MSchlawin at FVLHS.ORG
Tue Jan 19 18:37:14 UTC 2016


Hello everyone,
 
I just installed the GW 2104 R2 upgrade running on OES 11.1  I have been running dbcopy as a cron job for years to get a clean backup before I use BackupPC to get it to my backup server.  Something has happened and I cannot get dbcopy to run from cron.   I'm assuming it is related to the R2 upgrade.
 
Here is a snip from my backup script:
-----------------------------------------------------
# Create timestamp for start of job
rm /BACKUPVOL/gwbackup/gwbackupstart.txt
touch /BACKUPVOL/gwbackup/gwbackupstart.txt
#
# Copy primary domain fvlhs
/opt/novell/groupwise/agents/bin/dbcopy -d /media/nss/GWVOL/fvlhs/ /media/nss/BACKUPVOL/gwbackup/fvlhs/ 
#
# Copy teacher post office
/opt/novell/groupwise/agents/bin/dbcopy -p /media/nss/GWVOL/teachpo/ /media/nss/BACKUPVOL/gwbackup/teachpo/ 
#
# Create timestamp for end of job
rm /BACKUPVOL/gwbackup/gwbackupstop.txt
touch /BACKUPVOL/gwbackup/gwbackupstop.txt
-------------------------------------------------------------
 
and here is the line from crontab
# Backup GroupWise from GWVOL to BACKUPVOL every day at 12:30am
30  0  *  *  *  root /opt/novell/groupwise/agents/bin/gwbackup.sh
 
-------------------------------------------------------------
 
If you run the script manually from the command line, it runs just fine, just like it always did.
 
When cron runs the script at 12:30, a log entry is created in /var/log/messages saying the script started, so cron is working.
 
When cron runs the script, the start time and end time are both 12:30, so the script is running, but just bypassing the dbcopy lines.
 
I have tried directing the output of dbcopy to a log file.  ( using  >> ~/gwbackup.log   ) The gwbackup.log file is created, but it is empty.
 
I have tried putting the two dbcopy lines from my script directly into crontab.  Same results.  /var/log/messages shows they are running, but dbcopy does nothing.
 
Does anyone have an idea of how I can get cron to run dbcopy again?
 
Thanks!
 
Matt
 

 
 
 
 


More information about the ngw mailing list