[ngw] GWDVA crashing?

Gene Homan gene at genehoman.com
Thu Oct 6 01:14:14 UTC 2016


The below is from running 14.2.1.1  build 124595 ?




>>> "Joe Brugaletta" <JBrugaletta at braytonlaw.com> 10/05/16 3:57 PM >>>
for last day or so multiple gwdva processes on the server are eating quite a bit of CPU. Not sure if its playing catch up or what..and users are reporting searches are very slow.

(this paste from TOP might not come through sorted properly..)

  PID USER      PR  NI  VIRT  RES  SHR S   %CPU %MEM    TIME+  COMMAND
15504 root      25   5  353m 193m  11m R     96  1.9   3:29.30 gwdva
15344 root      25   5  249m  82m  10m S     50  0.8   1:06.60 gwdva
15688 root      25   5  162m  22m 9316 S     50  0.2   0:22.35 gwdva
 6039 root      20   0  521m 269m 9904 S      3  2.7 356:41.91 gwpoa

>>> "Gene Homan" <gene at genehoman.com> 10/4/2016 8:59 AM >>>
Make sure you have more than one DVA assigned to your POA.  I assign up to three per POA and stagger the load among a pool of three DVAs for all my POAs and WebAccess services in the same network location.  The WebAccess service puts a heavier load on the DVAs since its asking the DVA to convert the file to HTML format while the POA just asks for "word lists" to be sent back.

Make sure you are running build 124209 or newer of the DVA where Micro Focus improved the behavior of the DVA.  So 14.2.1.1 would have the DVA fixes in it.

Check the DVA log files (hope it was in verbose mode).  The latest DVA will auto cleanup the TMP files left behind by the Oracle Stellent subroutine.


>>> "Joe Brugaletta" <JBrugaletta at braytonlaw.com> 10/04/16 10:30 AM >>>
Every night at 8pm I get an email saying "QuickFinder Indexing will not start until the configured DVA is active"

If I check "rcgrpwise status" the gwdva is "dead".  Anyway to figure out whats happening? or any temp files that need to be cleared?




More information about the ngw mailing list