[ngw] GroupWise Webaccess Error [9527] and Potentially Related Mobility Issue

Cory Calvert calvertc at waterloo.k12.wi.us
Mon Apr 3 22:02:15 UTC 2017

I think that the problem is resolved now.

After looking through some SOAP traces, I found a folder listed with an ASCII 28 File Separator character at the end of the name.  I was able to find the folder in the GroupWise client, and it certainly was behaving oddly.  When I clicked on it, I'd still see the messages from the folder that I had been viewing continue to be displayed on screen, and when I tried right clicking and renaming or viewing properties, nothing would happen.  I tried deleting the folder, but then the next parallel folder, suddenly developed the same problem.

I ended up creating a new archive directory, archiving the folder structure one level above where I was having the problem, and then restoring the individual sub-folders back into my account.  The original problem folder is gone, as is the one next to it that developed the same issue.  I'm now able to log into WebAccess, and I suspect that our Mobility server will not crash tonight and that our Retain archive job will complete without errors.

Thanks for the suggestion, Mike, and also thanks to Pam for picking up the SR.

Cory Calvert
District Network Administrator
Waterloo School District
813 North Monroe Street
Waterloo, WI  53594
(920) 478-3633 ext. 8001

This message may contain confidential information and is intended only for the individual(s) named. If you are not a named addressee, you should not disseminate, distribute, or copy this e-mail. Please notify the sender immediately if you have received this e-mail by mistake and delete it from your system.

>>> "Michael Statman" <Mike at EMESConsulting.Net> 4/3/2017 10:10 AM >>>
I'd suspect that among the messages you returned from the archive into your live mailbox is one or more with invalid/corrupted character(s) in the Subject or From field.  You might be able to identify those from the win client and delete or archive them.

>>> "Cory Calvert" <calvertc at waterloo.k12.wi.us> 4/2/2017 2:23 PM >>>
When I try logging into WebAccess, the login page sits for a few seconds and then returns the following error:
[9527] Your request cannot be processed as the POA has returned an invalid XML. Please contact your Helpdesk.
So far as I can tell, the problem is specific to my account.  I have tested logging in as a different user and that worked fine, and I am able to see other users logging in and using WebAccess via the WebAccess web console.  I have not experienced any errors or strange occurrences while accessing my account through the GroupWise client.

I don't log in through WebAccess often, but I believe that this, and an issue with our Mobility server, started on Thursday, and probably have a common root cause.

One of our users discovered the Archive Directory setting in her GroupWise client earlier this school year, created an archive (on her C: drive, of course), moved a bunch of old messages into the archive, and then lost them all when her computer was re-imaged earlier this week.  In an effort to ensure that this couldn't happen again, I decided to disable the Archive Directory setting for everyone by locking it at the PO level (we have a small system with only one PO).  The downside to this plan was that I have been using such an archive for many years, and had to pull all of the messages stored there back into my account, as there doesn't seem to be any way to override that PO-level lock for a single user.

I found the following day that our Mobility server had stopped working.  One of the processes had crashed, and there was a backlog of about 40K messages that needed to be converted to mobile.  After working through the backlog (which involved restarting Mobility a couple of times after it seemed to stop processing messages), everything was caught up and seemed to be working.  I then found this morning that Mobility had stopped again on Saturday morning around midnight.  I suspect that whatever is wrong with my account that is causing the WebAccess problem is also responsible for the Mobility crash, since they both use SOAP to tie into GroupWise.  I tried re-syncing my Mobility account on Thursday, but the status has been stuck at Syncing-Days+ for a couple of days now, across multiple GMS restarts.

I've run Analyze/Fix operations with all of the options checked, both on just my account, and across all users in the PO.  I've verified and rebuilt the domain and post office databases, rebuilt my own user database, rebuilt indexes, and rebuilt my QuickFinder index.  At this point, I'm out of good ideas.  the GWCHECK log says that my account is perfectly fine, but something is still causing WebAccess to error.  Both WebAccess and our agents are running version 14.2.1 build 125534.

The POA, using verbose logging, shows the following information when I try to login to WebAccess:
11:24:16 A124 Initializing LDAP session with at port 636   App( SOAP )
11:24:16 A124 SOAP command end:[loginRequest] requested from   User session(calvertc) Elapsed Time (0.000)Secs
11:24:16 A124 SOAP command end:[loginRequest] requested from   User session(calvertc) Elapsed Time (0.000)Secs
11:24:57 A124 SOAP Action [getFolderListRequest] error rc=[8913]
The main WebAccess log doesn't showing anything too helpful:
11:24:16, <SOAP>, -, INFO, calvertc, Login
There is a large entry added to the WebAccess exceptions log at each occurrence though:
calvertc - 04/02/2017, 11:24:16,
- with linked exception:
[com.ctc.wstx.exc.WstxUnexpectedCharException: Illegal character ((CTRL-CHAR, code 28))
at javax.xml.stream.SerializableLocation at 713d2072]
	    at com.sun.xml.bind.v2.runtime.unmarshaller.UnmarshallerImpl.handleStreamException(UnmarshallerImpl.java:485)
	    at com.sun.xml.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal0(UnmarshallerImpl.java:417)
	    at com.sun.xml.bind.v2.runtime.BridgeImpl.unmarshal(BridgeImpl.java:124)
	    at com.sun.xml.bind.api.Bridge.unmarshal(Bridge.java:237)
	    at com.sun.xml.ws.db.glassfish.BridgeWrapper.unmarshal(BridgeWrapper.java:272)
	    at com.sun.xml.ws.message.stream.StreamMessage.readPayloadAsJAXB(StreamMessage.java:354)
	    at com.sun.xml.ws.api.message.MessageWrapper.readPayloadAsJAXB(MessageWrapper.java:201)
	    at com.sun.xml.ws.client.sei.ResponseBuilder$Body.readResponse(ResponseBuilder.java:582)
	    at com.sun.xml.ws.client.sei.StubHandler.readResponse(StubHandler.java:258)
	    at com.sun.xml.ws.db.DatabindingImpl.deserializeResponse(DatabindingImpl.java:203)
	    at com.sun.xml.ws.db.DatabindingImpl.deserializeResponse(DatabindingImpl.java:290)
	    at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:119)
	    at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:92)
	    at com.sun.xml.ws.client.sei.SEIStub.invoke(SEIStub.java:161)
	    at com.sun.proxy.$Proxy51.getFolderListRequest(Unknown Source)
	    at com.novell.webaccess.providers.soap.GWPortTypeFacade.getFolderList(GWPortTypeFacade.java:3288)
	    at com.novell.webaccess.providers.soap.GWPortTypeFacade.getFolderList(GWPortTypeFacade.java:3257)
	    at com.novell.webaccess.providers.soap.actions.SOAPActionHandlerFolders.reloadFolderList(SOAPActionHandlerFolders.java:1187)
	    at com.novell.webaccess.providers.soap.actions.SOAPActionHandlerFolders.folderList(SOAPActionHandlerFolders.java:1596)
	    at com.novell.webaccess.providers.soap.actions.SOAPActionHandlerFolders.folderList(SOAPActionHandlerFolders.java:124)
	    at com.novell.webaccess.providers.soap.actions.SOAPHandlerMediator.folderList(SOAPHandlerMediator.java:286)
	    at com.novell.webaccess.providers.soap.actions.SOAPActionHandlerLogin.checkAutosaveMessages(SOAPActionHandlerLogin.java:940)
	    at com.novell.webaccess.providers.soap.actions.SOAPActionHandlerLogin.userLogin(SOAPActionHandlerLogin.java:519)
	    at com.novell.webaccess.providers.soap.actions.SOAPActionHandlerLogin.userLogin(SOAPActionHandlerLogin.java:361)
	    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:95)
	    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:56)
	    at java.lang.reflect.Method.invoke(Method.java:620)
	    at com.novell.webaccess.providers.soap.actions.SOAPActionHandler.invoke(SOAPActionHandler.java:123)
	    at com.novell.webaccess.providers.soap.actions.SOAPActionHandler.service(SOAPActionHandler.java:72)
	    at com.novell.webaccess.providers.soap.SOAP.serviceX(SOAP.java:872)
	    at com.novell.webaccess.providers.soap.SOAP.service(SOAP.java:749)
	    at com.novell.webaccess.common.BaseServlet.callProvider(BaseServlet.java:1320)
	    at com.novell.webaccess.common.BaseServlet.onLogin(BaseServlet.java:1804)
	    at com.novell.webaccess.common.BaseServlet.service(BaseServlet.java:961)
	    at com.novell.webaccess.WebAccessServlet.service(WebAccessServlet.java:247)
	    at javax.servlet.http.HttpServlet.service(HttpServlet.java:723)
	    at com.novell.webaccess.common.BaseServlet.service(BaseServlet.java:797)
	    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	    at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:470)
	    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
	    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
	    at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:223)
	    at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:311)
	    at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:793)
	    at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:722)
	    at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:915)
	    at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	    at java.lang.Thread.run(Thread.java:809)
Caused by: com.ctc.wstx.exc.WstxUnexpectedCharException: Illegal character ((CTRL-CHAR, code 28))
at javax.xml.stream.SerializableLocation at 713d2072
	    at com.ctc.wstx.sr.StreamScanner.throwInvalidSpace(StreamScanner.java:666)
	    at com.ctc.wstx.sr.BasicStreamReader.readTextPrimary(BasicStreamReader.java:4576)
	    at com.ctc.wstx.sr.BasicStreamReader.nextFromTree(BasicStreamReader.java:2879)
	    at com.ctc.wstx.sr.BasicStreamReader.next(BasicStreamReader.java:1072)
	    at com.sun.xml.ws.util.xml.XMLStreamReaderFilter.next(XMLStreamReaderFilter.java:96)
	    at com.sun.xml.bind.v2.runtime.unmarshaller.StAXStreamConnector.bridge(StAXStreamConnector.java:196)
	    at com.sun.xml.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal0(UnmarshallerImpl.java:415)
	    ... 52 moreAny thoughts?

Cory Calvert
District Network Administrator
Waterloo School District
813 North Monroe Street
Waterloo, WI  53594
(920) 478-3633 ext. 8001

This message may contain confidential information and is intended only for the individual(s) named. If you are not a named addressee, you should not disseminate, distribute, or copy this e-mail. Please notify the sender immediately if you have received this e-mail by mistake and delete it from your system.

More information about the ngw mailing list