[ngw] Antw: Re: GW Crashing

Thomas Stimper tstimper at nmedv.de
Sat May 2 15:51:16 UTC 2020

i would check the hardware or VM host or VM configuration
Enough memory? is os swapping? How much?


Mit freundlichen Grüßen

Thomas Stimper

neue medien edv-systeme gmbh
Zwickauer Str. 224
09116 Chemnitz
Email tstimper at nmedv.de ( mailto:tstimper at nmedv.de )
Tel. +49 371 8448890
Fax +49 371 8448891
Amtsgericht / local court Chemnitz, HRB 12552
Geschäftsführer / CEO: Thomas Stimper
USt.ID / VAT DE176096756
Micro Focus Gold Partner

>>> "Matt Schlawin" <mschlawin at FVLHS.ORG> 02.05.2020 14:50 >>>
and one thing I forgot.  When the server came up this morning, I had
about 10 of these in my inbox:

Error that occurred: DA03-Problem message
Date/Time:  Friday,  1 May 2020 11:00pm
Type of message:    Individually tasked database maintenance
To requeue, save the last attachment to <post office

I checked, and the <post office path>\WPCSOUT\OFS\0 directory is
currently empty.


>>> "Matt Schlawin" <mschlawin at FVLHS.ORG> 05/02/20 7:21 AM >>>
Hello everyone,
With all the distance learning going on, this is a terrible time for GW
to start acting up.  Here is what I have been dealing with.

I'm running GW 18.1 on SLES 12.4.  All volumes are XFS.  I am running
one PO, MTA, and gwia on this box for about 100 users.  I have separate
servers for GMS, SMG and WebAccess.

The server has been running solid for months, but yesterday the entire
OS was locked up.  It would not even ping.  When I rebooted, it got
stuck in a boot loop.  I booted into recovery and it seemed to be OK for
a while, but then then entire server spontaneously rebooted several
times yesterday.  I was able to get it to boot and run in normal mode.

I did find some old stuck files in wpcsin and wpcsout that I moved out.
 I then had no inbound email because my MTA was not processing email.  I
found almost 300 email in <domain>/mslocal/mshold/<postoffice>/4  When I
moved them out, everything worked again.

It ran all day yesterday but this morning the PO was crashed.  I booted
from a rescue disk and did an xfs_repair on all the volumes to make sure
there was no file corruption.  

The server came up but the PO would not start.  I followed TID 7017465
and moved the ngwdfr.db from the ofmsg directory and that worked.

The server has been running for about an hour, but I am not optimistic
it will stay running.  I still have almost 300 messages again in
<postoffice>/ofmsg.  I'm guessing they should not be there?  I also
found over 400 *.ckl files in <postoffice>/wpcsout/chk   Not sure about
those either.

Can someone point me in a direction of what to do next.  Server is
running, email is flowing, but based on yesterday and today, I don't
think this will last.


More information about the ngw mailing list